Browse by topic/BlackBerry

Why isn't my BlackBerry supported?

Eric
posted this on April 01, 2013 15:59

Most BlackBerry phones with software version 4.6.0 to 7 are supported, but BlackBerry 10 isn't supported at the moment.

You can download Kik for your supported BlackBerry at kik.com.

BlackBerry phones that can't download Kik include:

  • Storm – models 9530, 9550
  • Pearl – models 8100, 8120, 8130, 8220, 8230, 9100
  • BB10
 
Topic is closed for comments